CrashPlan 4.4.1 released – Be careful when updating!

Patters from pcloadletter.co.uk just released a new version of his awesome CrashPlan package. This version introduces a new requirement so be careful when updating!

If you haven’t read my previous post about installing CrashPlan, I highly recommend you to start with that. Follow all instructions, but do not start the CrashPlan client at the end.

In order to upgrade to CrashPlan 4.4.1 you first need to update the package from “Package Center” on your Synology or XPenology server. All the settings changed in the third step in my previous guide will survive the upgrade, but you’ll have to re-download the .ui_info file.

Once the file has been downloaded, edit it and change the last value after the comma to your IP-address so it looks like this: 4243,123456-1234-1234-1234-123456789,192.168.1.100. The first value is the port number, second is your unique id and the last should be the IP-address to your server.

You’ll also have to modify the file ui.properties located at C:\Program Files\CrashPlan\conf and update your serviceHost.

You should also disable the CrashPlan service on your computer if you intend only to use the client. In Windows, open the Services section in Computer Management and stop the CrashPlan Backup Service. In the service Properties set the Startup Type to Manual.

 

Share this:

8 comments, add yours.

John

Hi Benjamin,
I upgraded Crashplan to 4.4.1. Something strange is happening.
Logged in as administrator!
Changed the IP-address in the ui.properties (C:\Program Files\CrashPlan\conf\ui.properties) and remove #.
Copied the .ui_info from the headless to C:\ProgramData\CrashPlan\.ui_info (override it)
Crashplan version headless (Synology): 4.4.1-0034
Crashplan version client: 4.4.1 (1435726800441)
guid: 711060XXXXXXXXXXXX (headless & client)
.ui_info client (working): 4243,e87100a7-4017-4bbd-8bd9-9198c9149595,192.168.1.72
.ui_info headless (Synology): 4243,e87100a7-4017-4bbd-8bd9-9198c9149595,0.0.0.0
This is working fine.

Everytime when I restart the client the values in .ui_info changed:
.ui_info client (2015-10-14): 4243,21a7fa56-6b7d-4b51-b367-929476404f44,127.0.0.1
.ui_info client (2015-10-15): 4243,d029f034-d677-403e-a5dd-a5df87317d5d,127.0.0.1
So I have to change them everyday.

Do you have a solution for this?

Kind regards,

John

Benjamin Krause

Benjamin Krause

Author

Hi,

I’m not completely sure as I don’t have this issue myself. I would try the following:

1. Close all instances of Crashplan using task manager
2. Go to services and make sure CrashPlan Backup Service is set to disabled and not running
3. Delete the local .ui_info file and transfer it again from your server. Remember to add your IP as you did before.
4. Reboot and see if it works

John

Hi Benjamin,

It didn’t work.

John

Benjamin Krause

Benjamin Krause

Author

Have you tried to uninstall the CrashPlan package and do a fresh install?

John

Yes I did,
Uninstalled on Synology (headless) and client. Re-install on Synology, start, stop, start. Install the latest download on the client.
Changed IP, copied ui_info, etc. etc. etc.
But still the same problem.

Niel

Hi John

I have exactly the same problem …

Niel

Benjamin Krause

Benjamin Krause

Author

That’s really weird. I’m not able to reproduce the issue for now. I’m on a business trip right now, but I’ll take another look at it once I’m home.

Victor

Hi,

Excellent instructions. Although it did not work immediately for me.
Server crashplan install, no issues.
I then installed 4.4.1 client on top of the previous one and then I had 2 installations. this messed things up a bit. I had uninstall all of them and reinstalled 4.4.1 only, followed your instructions and it worked like charm.

All in all always a bit of a nightmare with every upgrade. I am considering stepping to idrive. although in Europe the service is a bit sluggish

thanks!

Victor

Leave a comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.